After updating to 1.28.0-beta0 (from 1.27.0-beta1), ctrl-shift-e keyboard shortcut does something weird


#1

My keymap.cson file:

'.platform-linux, .platform-linux .command-palette atom-text-editor': {
  'ctrl-`': 'command-palette:toggle'
}

'atom-workspace':
  'ctrl-shift-`': 'fuzzy-theme-switcher:toggle'

'body': {
  'ctrl-shift-E': 'pane:split-right-and-copy-active-item',
  'ctrl-shift-O': 'pane:split-down-and-copy-active-item',
}

'atom-text-editor': {
  'ctrl-shift-X': 'hey-pane:toggle-focus-of-active-pane',
  'alt-g l': 'git-log:show'
}

I’ve had the same keymap file for basically the last year. I especially use ctrl-shift-e a lot to split-copy my current pane to the right, but after updating, I immediately noticed that was broken – instead, it types the letter e and if the keybinding resolver is active, it doesn’t register anything.

This is in contrast to ctrl-shift-o, which still works as expected. Halp please. What can I do to troubleshoot this?

PS: Safe mode makes no difference and this is definitely a new behavior of the new beta – it’s like ctrl-shift-e is some new unregistered shortcut. What it actually does is type an e but at the same time, it makes it so the e is highlighted (a la shift) … but even weirder, if you keep typing, the highlight follows you, beeping with each keypress (as if you’re typing somewhere you shouldn’t). Weirdest of all, if you type 9 more characters, the whole highlighted block of text disappears (e.g., if you do one more character after e12345678).


#2

Hey :wave:

It seems that this is a reserved keyboard shortcut in GTK3 to input emojis. Electron 2.0 is using GTK3.


#3

UGH.
Come to think of it, I remember having to disable that in ibus when I installed Fedora 28… is there an easy way to disable it in Electron?

If not, I guess it’s time to re-learn a keyboard shortcut I’ve been using for 10 years…


#4

I don’t know if there’s a way to disable it in Electron. Is there no global configuration in GTK3 to disable it?


#5

I don’t really know. All I know is that in Fedora 28, I had to use the ibus-setup command to remap ctrl-shift-e globally … and I’ve already done that, so whatever Electron is doing is something new.


#6

I found this ibus bug report. It suggests that the following might disable it for atom (but I haven’t tried it, so YMMV):

env GTK_IM_MODULE=gtk-im-context-simple XMODIFIERS=@im=none atom


#7

OK, that doesn’t work for me either. Blasted UI moving targets…


#8

Thanks for trying though! :slight_smile: