After trying to install linter I can't instally any package anymore


#1

After trying to install linter I can’t instally any package anymore. I have installed linter and it worked as first so I started installing some language packages for linter and now regardless of what package I try to install or uninstall I am getting this output:

npm ERR! Windows_NT 6.1.7601
npm ERR! argv "C:\\Users\\NearCZ\\AppData\\Local\\atom\\app-1.7.3\\resources\\ap
p\\apm\\bin\\node.exe" "C:\\Users\\NearCZ\\AppData\\Local\\atom\\app-1.7.3\\reso
urces\\app\\apm\\node_modules\\npm\\bin\\npm-cli.js" "--globalconfig" "C:\\Users
\\NearCZ\\.atom\\.apm\\.apmrc" "--userconfig" "C:\\Users\\NearCZ\\.atom\\.apmrc"
 "install" "C:\\Users\\NearCZ\\AppData\\Local\\Temp\\d-11644-4408-bhizur\\packag
e.tgz" "--target=0.36.8" "--arch=ia32"
npm ERR! node v0.10.40
npm ERR! npm  v2.13.3
npm ERR! file C:\Users\NearCZ\.atom\.apm\brace-expansion\1.1.4\package\package.j
son
npm ERR! code EJSONPARSE

npm ERR! Failed to parse json
npm ERR! Unexpected token '\u0000' at 1:1
npm ERR!

npm ERR! ^
npm ERR! File: C:\Users\NearCZ\.atom\.apm\brace-expansion\1.1.4\package\package.
json
npm ERR! Failed to parse package.json data.
npm ERR! package.json must be actual JSON, not just JavaScript.
npm ERR!
npm ERR! This is not a bug in npm.
npm ERR! Tell the package author to fix their package.json file. JSON.parse

I do not know how to format that output correctly so here is a screenshot, too.

I hope someone could help me and tell me what I must do to make apm working again. I tried searching but I did not find anything…


#2

I would try deleting the above directory and see if that helps.


#3

This was also filed here, with another potential fix.


#4

As a follow up from the discussion in the bug report, it turns out that @FrankenApps’s default text editor had added a BOM to the file which was breaking apm.