A way to hide the .DS_Store files in the tree view?


#1

I just opened a project of mine on my Mac OSX and I see the annoying .DS_Store files there.

Is there some way to hide these files?


#2

Preferences -> Tree View -> Hide Ignored Names

Edit: This’ll hide whatever you have listed in Preferences -> Settings -> Core Settings -> Ignored Names


#3


#4

Thanks for the info guys! Much appreciated!


#5

Just what I needed. Thanks!


#6

What if I want to note hide all ignored names (eg: I ignore node_modules, but found convenient to see it when I need to find some things inside this folder).
Is there any alternative solution so I can hide DS_Store or .git only ?


#7

You can hide VCS ignored files and/or Atom ignored files from the tree view, but no, you can’t select files to hide from the tree view and only the tree view. You can however easily toggle showing or hiding VCS ignored files by highlighting the tree view and pressing I, which may help for your use case.


#8

I found a way to be happy by going to Settings > Packages > tree-view and check Hide Ignored names and uncheck Hide VCS ignored files.


#9

That was painless. Thanks!


#10

It moved slightly.


#11

How do I make this feature cooperate with global git ignore settings?

(Typically, .DS_Store shouldn’t be in the project .gitignore file.)


#12

This is exactly what I was looking for. Thanks.


#13

Things have changed quite a bit since the original post in 2014. An update would be nice!

My project folder is showing .DS_Store and .git file despite the Core Settings > Ignored Names containing the default: .git as well as .DS_Store.

Why aren’t things working?


How to ignore .DS-Store in project
#14

I found the answer elsewhere, so I thought I’d share it here.

One needs to go to Packages and search for tree view. Open the tree view package’s settings and make sure that the “Hide Ignored Names” checkbox is checked.