A stupid nubie question, I guess. Please, help!


#1

Hi there!

Please, help me, because I’m lost. I’m trying to write some code, but the tags aren’t highlighted how they need to be. Also there is no live preview in the preview mode. What I’m doing wrong?


#2

Have you followed the suggestions in the Debugging document? Also, could you give the following information?

  • Which version of Atom are you using?
  • What OS and version are you running?
  • Can you reproduce the issue after completely exiting Atom and restarting using atom --safe?

I tried reproducing what you’re showing using Atom v1.7.0-dev-f88051e on Mac OS X 10.11.3 and got this:


#3

I think atom-html-preview is broken in version 1.5.4
There is an open issue posted here:

If you close the tab that has actual text, or drag the preview tab to the left, it should render it.


#4

For the record, my screenshot is using the built-in markdown-preview package which also previews HTML.


#5

Hi!

I looked through the Debugging, seems to be ok.

  1. I’m using the latest Atom 1.5.4;

  2. OS X El Captain 10.11.3;

  3. Here I got some problems. Tried to type in the console “open -a atom --safe”, but it didn’t work.


#6

Hi, yes! It worked, when I closed the tab with the main text.

Could you suggest, what to do? Can I find an earlier version anywhere?


#7

Just atom --safe without the open -a should work. If it doesn’t right away, open Atom normally and click the Atom > Install Shell Commands menu item. Then try atom --safe again :grinning:


#8

Ok, it opened safe!

But… I have another problem now: the html preview package disappeared from the “Packages” menu list :joy:


#9

Though it still exists in “Settings”:


#10

Atom’s Safe Mode is designed to disable everything that wasn’t installed with Atom itself. It is a diagnostic tool to determine if there is a problem with Atom, or with a third-party package. I misunderstood your original question to mean that you couldn’t preview the HTML file using the built-in markdown-preview package (which can be activated using Ctrl+Shift+M and previews HTML just fine). I’m afraid I have no experience with the atom-html-preview package.


#11

Ok, I see!
Will hope, that the bug will disappear in the future.

And yes, Ctrl+Shift+M works fine.

Thanks a lot for saving me from panic :slight_smile: ! The community is so nice here.
Will go and read further the Documentation :wink: .