A problem of plot with Atom Julia 0.4.2 win7 x64


#1

hello,
I got the error when trying to use the command “plot(rand(100))” on Atom after using Winston.
using Winston.
MethodError: convert has no method matching convert(::Type{Tk.TkWidget}, ::ASCIIString, ::ASCIIString)
This may have arisen from a call to the constructor Tk.TkWidget(…),
since type constructors fall back to convert methods.

Closest candidates are:
Tk.TkWidget(!Matched::Tk.TkWidget, ::Any)
call{T}(::Type{T}, ::Any)
convert{T}(::Type{T}, !Matched::T)

in make_widget at C:\Users\digiplante.julia\v0.4\Tk\src\core.jl:222
in Text at C:\Users\digiplante.julia\v0.4\Tk\src\widgets.jl:48
[inlined code] from C:\Users\digiplante.julia\v0.4\Atom\src\display\objects.jl:16
in render at C:\Users\digiplante.julia\v0.4\Media\src\system.jl:165
[inlined code] from C:\Users\digiplante.julia\v0.4\Atom\src\eval.jl:41
in anonymous at C:\Users\digiplante.julia\v0.4\Atom\src\eval.jl:108
in withpath at C:\Users\digiplante.julia\v0.4\Requires\src\require.jl:37
in withpath at C:\Users\digiplante.julia\v0.4\Atom\src\eval.jl:53
[inlined code] from C:\Users\digiplante.julia\v0.4\Atom\src\eval.jl:107
in anonymous at task.jl:58

but it works well with the julia shell.
could anyone help me with it?
thanks


#2

Atom is a text editor. It doesn’t build or execute code out of the box. See the FAQ:

It sounds like you’re running into a problem with a specific Atom package that you’ve installed to run Julia code. In that case you may want to contact the maintainers of that package. The FAQ also has information on contacting the maintainers of any Atom package or theme: