A Package for FormatForLua is needed


#1

As a game developer , Cocos2d-Lua is used normally.
We use sublime as lua developer editor.
I try to use atom for lua code.
I installed FireZenk’s Lua language and saschagelich’s Autocomplete Plus
I also need a lua format

I found lua format function is not common in most editor.


#2

You could convert the TextMate Lua bundle: https://github.com/textmate/lua.tmbundle

By following the instructions here: https://atom.io/docs/v0.83.0/converting-a-text-mate-bundle


#3

thank you, I will try it later