1.14 - 1.16 is forcing a line wrap even with soft wrap toggled off


#1

I just upgraded form 1.12 to 1.16 and noticed that atom now forces a line wrap at a certain length even with soft wrap disabled.
In 1.14-1.16:


In 1.12:
(added below because of image limit)

In the past It was possible to have the entirety of the line in the editor without it soft wrapping. Is this still possible. For now I have gone back to 1.12 but I’d love to be able to use the new version.


#2


#3

This was an intentional change made in 1.15 to prevent Atom from hanging in some cases -
see for example this post for more discussion:

The pull request introducing this behavior is here /cc https://github.com/atom/atom/pull/13820.


#4

Looks like this is a hard coded feature now controlled by the variable MAX_SCREEN_LINE_LENGTH. I edited and recompiled form source. I may open a PR to make it adjustable


#5

I may open a PR to make it adjustable

Maybe a language setting.

Like in javascript you probably want to enfore 500 while in plaintext / markdown you may support larger line.


#6

If I may share my opinion,
This is a terrible solution to the slowness issues. I want my lines long! at least give me the option to set it, or at least mention that it is impossible. I had been searching for a solution for a long time.
By the way, the editor is still slow.
I am going back to my good old Notepad++
Cheers.


#7

This should definitely not be a silent feature as the settings menu does not mention anything about this. But I agree with itgoldman.