0.176.0 no longer works within corporate firewall [workaround]


#1

I’ve been unable to install packages since the 0.176.0 update switched to npm 2.3.0. I finally managed to get updates to install by using the old 0.175.0 release, which has an older version of npm. I’m creating this thread so other people who stumble upon this issue will know what to do to solve it.

Background:
My computer at work is behind a corporate firewall that intercepts SSL communications and signs it with its own CA certificate. This blows up everything that uses its own internal CA store, which is pretty much all of Atom and everything it uses. It makes life difficult for some of us.

Old workaround:
We used to be able to create a %USERPROFILE%\.npmrc file that contained strict-ssl = false to disable SSL security checks with npm, as well as disabling security checks with git (git config --global http.sslVerify false). This worked until npm 2.3.0. Its probably a bug, but somewhere down the chain of dependencies it starts checking certificates again, and everything blows up.

New modified workaround:
Make sure you disable SSL checks like above. Then, find the old 0.175.0 version of Atom and install it. You can find it on this github page: https://github.com/atom/atom/releases

After it is installed, navigate here:
%LOCALAPPDATA%\atom\app-0.175.0\resources\app\apm\bin

Run: apm.cmd upgrade

The upgrade should complete successfully. At least it did for me.


Atom compile behind corporate firewall: npm https header
"Device not configured" When Installing Packages
#2

You can get the official built version of Atom since forever on the project’s GitHub Releases page:


#3

This is a verified regression in npm 2.3.0. I’ll bump the topic when it gets fixed in npm and rolled into Atom in the future.


#4

Hi All,

This npm thing is still a problem for me on RHEL6 linux behind a corporate firewall. I have been trying for a several hours now to install a newer version of atom with new versions of node (5.0.0.rc1) and npm (3.3.9) with no success. Our deployed glibc is too old (2.12) to run the compiled versions of atom which AFAIK require glibc > 2.14 (glibc is backward compat but not forward compat).

I can get partway through the install and then get the same problem as discussed in issues 9211 and 322. As soon as the deployed npm in the atom install goes beyond 1.4.23, the installation fails for me. I will have to roll back atom even farther because 0.175.0 uses npm 1.4.28.

As an aside, I have never done anything with js, and if anyone could clue me into a way to get a little more information from the build system I would appreciate it. For example: how could I set --loglevel “info” for the build?

If there is a better way to workaround this npm issue I would love to try it. TIA.